The support forum

ProcessReparsePoint() errors on node_modules directory

tylerisrandom :

Sep 27, 2017

Greetings!

Brand-new user currently in the trial period but loving the app so far. :)

My only complaint is that every sync shows errors for node_modules directories. The errors are all the same:

ProcessReparsePoint() failed with a000001d

Context: D:\path\to\project\node_modules\path\to\module


There are no other errors and no variation between the errors except the "path\to" segments.

What's particularly strange is that in my settings, I have a rule to "Exclude folder node_modules". I don't need them copied over, but the errors still persist.

It's not really a dealbreaker because the backup is succeeding, it's more just noisy to see errors every time when it's working exactly as I'd expect it to.

Alex Pankratov :

Sep 27, 2017



This looks like one of more obscure reparse point types, it's not even documented properly. Bvckup 2 simply doesn't know what to do with it and it complains to... erm... raise the awareness :)

I'll get this added to the next release, but meanwhile:

1. Right-click on the backup job
2. Select Open folder > Configuration & Logging
3. In Notepad create a text file called override.ini and put this in it:

        conf.scanning.rp_as_normal.f    a000001d
        conf.scanning.rp_as_normal.d    a000001d

4. Save the ini, restart bvckup2

---

Re: the fact that it still complains even though these entries are excluded from the backup - this is because reparse points are processed first and exclude/include filters are applied next. But it makes sense to revise this to cleanly accommodate your exact setup. Let me see what we can do.

tylerisrandom :

Sep 30, 2017

I followed the steps you provided and the backup now runs successfully with "no errors." Thanks for your help! :)

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Dev blog
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy