The support forum

Device I/O error

AlexT :

Aug 17, 2016

Hey guys,
I've been running Bvckup2 for about a couple of weeks now and without any huge problems
But now I always get the following when I run the backup...Aborted: Device I / O error
Does anyone know why I get this error and know a solution?

Thanks in advance
Alex

Alex Pankratov :

Aug 17, 2016

It's either a dying disk or an issue with device firmware or its Windows driver. It can also be something more exotic such as an USB device that is not fully USB-compliant knocking offline other USB devices on the same hub, but that's rather unlikely.

AlexT :

Aug 18, 2016

Thank you Alex!
I run two backup's after each other, first of files from my C-drive and then files from my D-drive
The strange thing is just that it is only the C-drive backup job that provides the I/O error and never the D-drive job
The backup media is a whole new and very fast external HDD from Seagate
Can you based on these informations say anything more precise about what is wrong Alex?

Alex Pankratov :

Aug 19, 2016

Hold on, was the error reported for the source side or the backup side? Look in the log - you should see an error message attached to one of the backup steps and it will have the exact context (i.e. the name of a file that tripped the error).

mPalma :

Apr 18, 2017

I am having the same issue. I have been running this backup for over a year but this just started. It is the destination drive getting the error. The weird thing is I run 2 separate backups to that drive.  The starting drive is the same for both and the destination drive is the same for both. The only difference is I am backing up different directories. For example:

First Backup:
Backup From - \\CLOUDLIVINGROOM\Public\Documents\
Backup To - \\READYSHARE\USB_Storage\Documents\

Second Backup:
Backup From - \\CLOUDLIVINGROOM\Public\Kelly Files\
Backup To - \\READYSHARE\USB_Storage\Kelly Files\

Since one job works and the other gets the error how can that be the drive failing or a USB problem?

Froggie :

Apr 18, 2017

mPalma... your backups are dealing with files on different areas of the drive storage medium, one may e going bad on you.

Alex Pankratov :

Apr 19, 2017



@mPalma -

Bvckup 2 merely reports an error received from Windows in response to some of its requests. The error can be caused by anything on the path between Bvckup 2 and your backup device. Given the error type ("device IO error") it's likely to originate at the device level rather than at the file system level and this means either an issue with the device itself, its connection or the connection to/from the host that its attached to. The latter can in turn be an issue with the host itself or an issue with an intermediate router / access point. In any case, something somewhere goes belly up.

As to why it happens for one job and not for another is a good question. I would guess it's due to one job generating more data load than another -or- one in fact hitting a bad patch on your storage media.

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Dev blog
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy