The support forum

Version 79->80 Breaks Symbolic Links

estevens99 :

Jul 15, 2019

Upgrading from version 1.79.1.0 to version 1.80.1.1 causes all of my symbolic link based folders to fail with the following error:  

ProcessReparsePoint() failed with 3

My setup:

I have a Windows machine with a network share that I sync my local PC with.   On that remote windows machine, the shared folder contains some folders that are symlinks to other folders/drives on that remote machine.  

I map a drive on the machine running Bvckup to the share on that remote machine in order to sync files from that remote machine to my local machine.    

Version 1.79 (and every version prior to it that I ran over the past few years) worked well.   But when version 80 hits those remote symlinks, it fails with the ProcessReparsePoint error above.


I can reproduce the issue by rolling back to version 79... everything works correctly... upgrade to 80, I get error... rollback to 79, everything works...

Alex Pankratov :

Jul 15, 2019



There were no relevant changes to the symlink processing between these two releases. The error code itself means that the reparse type for this symlink was reported by Windows as 0x00000003 instead of 0xA000000C.

This makes very little sense, so as per usual please check that bvckup2.exe access to the file system is not being quarantined, policed or otherwise hindered by any antivirus/antimalware/security software that you might be running on the local side.

I'll try and reproduce this next, but it would help to know what's the remote end exactly in your case? That is, is it a native Windows or is it some sort of non-Windows box accessed with Samba or similar.

New topic

Create
Made by Pipemetrics in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy