The support forum

Start Minimize option not working

Andreas :

Mar 29, 2018

Hello!

Since I updated to Windows 10 (1709) the option mentioned in the subject line is not working anymore. The program is not stored / copied to the autostart folders or somewhere else. I activated the options in the preferences:

Launch on  startup
Launch with admin rights
Start minimized

After some restarts the option "start minimized" is deactivated / unchecked and the program does not start minimized anymore. Any tips?

Thank you and happy Easter! :)

Alex Pankratov :

Mar 30, 2018



This preference is stored in %LocalAppData%\Bvckup2\ui\bvckup2-ui.ini file, which the program reads on launch.

If this setting gets unchecked, it means that .ini  is getting wiped, which in turn is typically done by an overzealous antivirus. I'd dig in that direction.

If this setting remains checked, but the program doesn't start minimized, it means that the program is auto-started _twice_. In this case the second launch will act as a "show yourself" signal, so the window will restore itself from a minimized state.

Homer712 :

Apr 25, 2018

Have had the same issue for a while now. Only antivirus installed is Windows Defender, and thinking that may be the issue I have Defender not scanning the Local\AppData\Bvckup2 folder. Also have this folder protected from scans/cleaning by CCleaner. Still, the "Start Minimized" option gets unchecked by something as it doesn't stick between starts/restarts.

Alex Pankratov :

Apr 25, 2018



Hmm... have you noticed if the window position/size gets reset too when "start minimized" gets unchecked?

Or, better yet, can you reproduce this at will? That would've been the shortest path to a resolution.

Homer712 :

Apr 25, 2018

Just logged in to comment on just that. The window position AND size is changed, AND even though I've done the "leave a comment" thing a number of times, when the app is NOT minimized on startup, this same "leave a comment" is once again at the bottom of the window. I've taken a look at the *.ini files and they all have the same date/times stamp. Don't know if they should, the names are different, so I expected them to have different time stamps.

Alex Pankratov :

Apr 25, 2018

It means that the INI file that bvckup2 uses to store all its UI-related settings is getting wiped out _or_ corrupted. In either case the cause is external to the program, so there's not much you can change in the program itself to resolve this.

If you'd like I can take a look at your %LocalAppData%\Bvckup2\bvckup2.log to see what's happening exactly. Perhaps it may help you to track down why this is happening.

Homer712 :

Apr 25, 2018

That would be great. There are three log files: *.log, *-fsi.log and *-vss.log. Which one (or all) would you like. Way too long to post here. And, where to send it?

Alex Pankratov :

Apr 25, 2018

Just the .log (and it should compress well). The email is support@pipemetrics.com

Homer712 :

Apr 25, 2018

On it's way!

Homer712 :

Apr 25, 2018

And just in case it matters (with Windows 10, it seems everything matters!), I have changed my power settings so when I do a "Shut Down", Windows does not go into hibernation and that "Quick Startup" thing, but a total, complete, true shut down.

Alex Pankratov :

Apr 26, 2018

Ok, I think I have it figured out.

This happens around Windows restrarts - Windows will indicate that it is shutting down, the UI will initiate saving of its INI file, but Windows will nuke the process half-way through. The program hedges against that by first stashing existing copy of the ini, but the problem was that it would not try using it *unless* the main copy of ini exists and unusable.

Long story short - this is fixed now, will go out with the next release in a couple of days. Thanks a bunch for your help.

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Blog / RSS
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy