The support forum

Preparing the backup taking forever

pplante19 :

Feb 09, 2018

Hi everyone,  I have a backup plan on our server (Windows Server 2008 R2) that replicates the content of a disk (RAID6 with 6 disks, 6 x 4Tb for a big 13,6Tb drive) on which only 1Tb is currently taken to another disk (RAID0 with 2 disks, 2 x 10Tb for a bigger 17,5Tb drive), so everything from disk 1 is being copied on disk 2, with permissions, it's a kind of backup/mirror.

As of today on disk 1, I have 1,03Tb of data that comes from 837,707 files and 35,894 folders.

The original backup took almost a day and yesterday I started another run at about 1AM and now it's 8AM here, so it's running for 7 straight hours, and I'm at the 'Preparing the backup plan' step with, so far, at 43,352 steps ..., I'm saying so far because sometimes, it goes up by a little margin. It took about 2 hours to scan the source.

I attached, with Google Drive, some screenshots for you to see my backup config and setup, maybe you could see if there's something wrong about it.

https://***redacted***

I used your software in the past personnally and it worked very well, that's why I'm trying to implement it on our business now, but it seems pretty 'slow'  compared to my home use. I know I have much more files and that it copies permissions, but should my config take so long to copy? It's been almost 7 hours and it even started to duplicate the content. Is there tricks to make it faster?

Thanks a lot for your help on this matter.

Alex Pankratov :

Feb 09, 2018

To echo what I replied via email - this is most likely caused by having a fair amount of files being both created and deleted between the runs *AND* having a move/rename detection enabled for the job.

This is a new issue, we became aware of it only earlier this week, so there's no patch for it yet. The workaround is to disable move/rename detection in backup settings (the More Options section).

If it's absolutely necessary to have move detection enabled (e.g. if there are large files that are getting routinely moved around between the backups), then it's possible to reduce the detection mechanism to its bare minimum and have it use only one detection method instead of three that it uses by default. I can explain the details, just let me know.

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Blog / RSS
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy