The support forum

Cannot get exclude folders to work

Brendan :

Jan 09, 2018

Hi all,

I'm probably being really thick here but I can't get exclude folders to work.

Let's say I want to back up all my MP3 files, except for, say, The Beatles. They're all on my D: drive, in a folder called Music.

My rules are set up as:
Include file *.mp3
Exclude folder D;\Music\The Beatles

It just backs up everything and doesn't exclude The Beatles. I've tried this both ways around ie excluding folder first then including files second, also specifying the exclude folder as just The Beatles, or specifying it as The Beatles\*,mp3 and so on. Just cannot get it to work,

I'm sure I'm missing something very obvious here. Can anyone help?

Thanks
Brendan

Alex Pankratov :

Jan 10, 2018



What an "exclude" rule does is it sets a default action for all items in the folder and it also marks the folder itself for exclusion IF all its items ends up being excluded.

However, this rule doesn't prevent other rules from being applied to the folder's items, which is what's happening in your case.

This behavior can be changed. More specifically, it's possible to make rules "final", meaning that when they are applied to a folder, they determine the outcome for all folder's items, full stop, all other rules are ignored.

This is controlled by the following entry in job's configuration file:

        conf.filters.src.verbose.exclude_is_final    1

See https://bvckup2.com/support/forum/topic/933 for details on how to find and edit settings.ini for the job.

Brendan :

Jan 10, 2018

Thanks for responding. I've done this but it still doesn't work.

I've edited the settings.ini file for the job, setting conf.filters.src.verbose.exclude_is_final to the value 1, and still have the other two rules set up, but it's just not excluding that folder.

The other two rules are set up as:
Include file *.mp3
Exclude folder D:\Music\The Beatles

It's still just copying everything, including that folder, no matter which way around I specify the rules, and I've checked that I've correctly edited the right ini file for the job.

I'm clearly missing something here. Is it the way I'm specifying the exclude folder eg should it be just \The Beatles or something?

Alex Pankratov :

Jan 10, 2018

Have you seen this https://bvckup2.com/support/forum/topic/499 topic? It explains the format of the patterns, including the difference between foo\bar, .\foo\bar and x:\foo\bar variants.

If your source folder is x:\foo and you want to exclude x:\foo\bar\beatles, then the filter pattern will be .\bar\beatles. Also, check that you are excluding _folders_, because the UI for adding a new filter defaults to matching _files_.

Alex Pankratov :

Jan 10, 2018

Ah, damn. Sorry, my mistake. The correct ini entry is

        conf.filters.src.generic.exclude_is_final    1

That is with "generic", not "verbose" in the middle.

"Verbose" is for exclusions/inclusions made in the middle pane (the point-and-click part) of the filter configuration UI, and "generic" is for the rules specified at the bottom of it.

Brendan :

Jan 11, 2018

No problem - but I still can't get this to work. I'm sure I'm using the right pattern, and now I'm using the right ini setting too, but it just says 'No changes' ie it's not removing the folder that I don't want to copy.

I've tried doing this the other way ie starting with all folders and manually excluding the ones I don't want to backup, but this isn't the ideal behaviour I'm looking for. I just want to be able to keep adding to the folder, and have what I add backed up, with some exceptions.

If you're saying that I should:
* set  conf.filters.src.generic.exclude_is_final    1 (making sure Bvckup isn't running when I set this, and checking it is set when Bvckup is running again)
* set my rules as:
Include file: *.mp3
Exclude folders: .\Music\The Beatles (bearing in mind I'm running Bvckup from the C: drive and the data is on the D: drive)

... then this doesn't seem to work.

Alex Pankratov :

Jan 12, 2018

I managed to reproduce this.

The filtering module was effectively ignoring the "generic_exclude_is_final" override, so it would in fact not respect the "final" qualifier for the "Exclude Beatles" rule.

The fix is already in. If all goes well, we should be able to get an update out later today.

Thanks for your persistence and patience, much appreciate both.

Alex Pankratov :

Jan 15, 2018


OK, the fix is out in a form of 78.18. Manual update link is https://bvckup2.com/update

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Blog / RSS
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy