The support forum

Application Error 0xc0000005 (Access Violation) on startup

paulw :

Nov 08, 2017

Just discovered that I cannot start bvckup from it's executable.

Tried uninstallng and reinstalling. Have also removed the service.
Windows 10 Version 1703 Build 15063.674

There is no new log file created in either
C:\ProgramData\Bvckup2 or
C:\Users\paulw\AppData\Local\Bvckup2

Event log is as follows:

Faulting application name: bvckup2.exe, version: 1.78.10.0, time stamp: 0x59ef67e1
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000000000028ae40
Faulting process id: 0x724
Faulting application start time: 0x01d358c1da30fc83
Faulting application path: C:\Users\paulw\Program Files\Bvckup 2\bvckup2.exe
Faulting module path: unknown
Report Id: 39591f52-f652-4c4c-aa9d-aa3c3bf40600
Faulting package full name:
Faulting package-relative application ID:

I have also tried renaming existing directories and retrying. Same result.

Finally uninstalled and opted to remove application data completely. Reinstalled but same result.

Can you suggest what to try next.

Thanks
-paul

Alex Pankratov :

Nov 09, 2017

Disable your antivirus(es) and give it another try.

Bvckup 2 has a built-in crash detector, so it will always show a message if it ever crashes in its own code. Since you are not seeing the message, it is crashing in some other code that was injected into its process and that's a telltale sign of antiviruses and other security software.

paulw :

Nov 09, 2017

Hmm. Might be difficult. It is running in a corporate environment.

paulw :

Nov 09, 2017

Turns out that due to a problem remotely managing my machine that I don't actually have the expected AV software installed only the firewall software. btw it is McAfee and Windows Defender is disabled by group policy.

So maybe it is something else?

Alex Pankratov :

Nov 12, 2017

Paul, I really can't tell.

Literally, the first thing that the program does when it starts running is that it creates the log file and then it installs a custom exception handler. Neither seems to be happening in your case, meaning that if the crash does in fact originate in the bvckup's own code, it happens very early on... but this sort of issue would've surfaced long time ago.

My gut feeling is that you have some of the native Windows APIs intercepted on your machine and the interception routine is buggy. It's possible that McAfee is still hooking the APIs even though it is formally "disabled" on the machine.

One way to track this down is to try and get a stack trace from the crash. However it may or may not be available from the Event log.

In any case, I'd suggest we take this over to email. It'd be faster and simpler that way.

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Dev blog
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy